import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=^FS-[a-zA-Z0-9]*)[a-z]|[\\p{Zs}\\ta-z](?=[a-zA-Z0-9\\p{Zs}\\t]*$)";
final String string = "(S)FSK-69/23/GFK/ 1 2 \n"
+ "(S)FSK-69/23/GFK/12\n\n"
+ "FS-4444g/23g/F/1g1\n"
+ "FS-4444/23g/F/11";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}