using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=\D*(?:\d\D*){1,12}$)\d+(?:\.\d{1,4})?$";
string input = @"Max length of the number is 12 character
If there is a decimal point in number then the user can add a maximum of 4 digits after the decimal point and minimum 1 digit.
Valid Inputs:
222244445555
22223333.3333
5555.33
1.2
0.33
11112222333.3
InValid Inputs:
22.
.11
2222333344443
444445555544.
333344445.1234";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}