$re = '/^(?=\D*(?:\d\D*){1,12}$)\d+(?:\.\d{1,4})?$/m';
$str = 'Max length of the number is 12 character
If there is a decimal point in number then the user can add a maximum of 4 digits after the decimal point and minimum 1 digit.
Valid Inputs:
222244445555
22223333.3333
5555.33
1.2
0.33
11112222333.3
InValid Inputs:
22.
.11
2222333344443
444445555544.
333344445.1234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);