import Foundation
let pattern = #"^(?=\D*(?:\d\D*){1,12}$)\d+(?:\.\d{1,4})?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Max length of the number is 12 character
If there is a decimal point in number then the user can add a maximum of 4 digits after the decimal point and minimum 1 digit.
Valid Inputs:
222244445555
22223333.3333
5555.33
1.2
0.33
11112222333.3
InValid Inputs:
22.
.11
2222333344443
444445555544.
333344445.1234
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)