import re
regex = re.compile(r"^(?=\D*(?:\d\D*){1,12}$)\d+(?:\.\d{1,4})?$", flags=re.MULTILINE)
test_str = ("Max length of the number is 12 character\n"
"If there is a decimal point in number then the user can add a maximum of 4 digits after the decimal point and minimum 1 digit.\n\n"
"Valid Inputs:\n"
"222244445555\n"
"22223333.3333\n"
"5555.33\n"
"1.2\n"
"0.33\n"
"11112222333.3\n\n"
"InValid Inputs: \n"
"22.\n"
".11\n"
"2222333344443\n"
"444445555544.\n"
"333344445.1234")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")