const regex = /^(?=\D*(?:\d\D*){1,12}$)\d+(?:\.\d{1,4})?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=\\D*(?:\\d\\D*){1,12}$)\\d+(?:\\.\\d{1,4})?$', 'gm')
const str = `Max length of the number is 12 character
If there is a decimal point in number then the user can add a maximum of 4 digits after the decimal point and minimum 1 digit.
Valid Inputs:
222244445555
22223333.3333
5555.33
1.2
0.33
11112222333.3
InValid Inputs:
22.
.11
2222333344443
444445555544.
333344445.1234`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}