using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*\w{8}-\w{4}-\w{4}-\w{4}-\w{12}\s*:\s*com.netflix.hystrix.exception.HystrixRuntimeException:\s*(?<error>.*?)\s*(\.|$)";
string input = @"2021-02-22 00:58:30,255 ERROR [com.xxx.yyy.interfaces.exceptions.web.ServerErrorController] (ajp-/100.10.100.100:8000-10) Unexpected failure: GET /yyy/api/zzz/aaa 500 - User: 1XX1XX1X-1X11-1111-1X11-111X11111111: com.netflix.hystrix.exception.HystrixRuntimeException: Error message.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}