import Foundation
let pattern = #".*\w{8}-\w{4}-\w{4}-\w{4}-\w{12}\s*:\s*com.netflix.hystrix.exception.HystrixRuntimeException:\s*(?<error>.*?)\s*(\.|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"2021-02-22 00:58:30,255 ERROR [com.xxx.yyy.interfaces.exceptions.web.ServerErrorController] (ajp-/100.10.100.100:8000-10) Unexpected failure: GET /yyy/api/zzz/aaa 500 - User: 1XX1XX1X-1X11-1111-1X11-111X11111111: com.netflix.hystrix.exception.HystrixRuntimeException: Error message."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)