const regex = /.*\w{8}-\w{4}-\w{4}-\w{4}-\w{12}\s*:\s*com.netflix.hystrix.exception.HystrixRuntimeException:\s*(?<error>.*?)\s*(\.|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*\\w{8}-\\w{4}-\\w{4}-\\w{4}-\\w{12}\\s*:\\s*com.netflix.hystrix.exception.HystrixRuntimeException:\\s*(?<error>.*?)\\s*(\\.|$)', 'gm')
const str = `2021-02-22 00:58:30,255 ERROR [com.xxx.yyy.interfaces.exceptions.web.ServerErrorController] (ajp-/100.10.100.100:8000-10) Unexpected failure: GET /yyy/api/zzz/aaa 500 - User: 1XX1XX1X-1X11-1111-1X11-111X11111111: com.netflix.hystrix.exception.HystrixRuntimeException: Error message.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}