#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^\d+\s(?<Quantity>\d+?)(?:EA|RL|BX)\s(?:(?:ABC|DEF|GHI) (?<AltID>.*?) )?(?<Description>.*?) (?<PriceEa>\d+\.\d+)\/ea \d+\.\d+(?:(?:(?!(?:^\d+\s\d+ea|UPC:))(?:.|\n))+)?(?:UPC:\s?(?<PartNum>(?!^).*?))?$"
Local $sString = "1 60ea ABC A1234-16-32 Description here 8.88/ea 532.80" & @CRLF & _
"Possible Extended Description here - do not need this" & @CRLF & _
"UPC: 1234567890" & @CRLF & _
"2 20ea DEF 866 1562PL Description here 4.44/ea 88.80" & @CRLF & _
"UPC: 2234567890" & @CRLF & _
"3 10ea GHI 34-12-66-12 Description here 2.22/ea 22.20" & @CRLF & _
"Possible extended description"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")