# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\d+\s(?<Quantity>\d+?)(?:EA|RL|BX)\s(?:(?:ABC|DEF|GHI) (?<AltID>.*?) )?(?<Description>.*?) (?<PriceEa>\d+\.\d+)\/ea \d+\.\d+(?:(?:(?!(?:^\d+\s\d+ea|UPC:))(?:.|\n))+)?(?:UPC:\s?(?<PartNum>(?!^).*?))?$"
test_str = ("1 60ea ABC A1234-16-32 Description here 8.88/ea 532.80\n"
"Possible Extended Description here - do not need this\n"
"UPC: 1234567890\n"
"2 20ea DEF 866 1562PL Description here 4.44/ea 88.80\n"
"UPC: 2234567890\n"
"3 10ea GHI 34-12-66-12 Description here 2.22/ea 22.20\n"
"Possible extended description")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.