import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d+\\s(?<Quantity>\\d+?)(?:EA|RL|BX)\\s(?:(?:ABC|DEF|GHI) (?<AltID>.*?) )?(?<Description>.*?) (?<PriceEa>\\d+\\.\\d+)\\/ea \\d+\\.\\d+(?:(?:(?!(?:^\\d+\\s\\d+ea|UPC:))(?:.|\\n))+)?(?:UPC:\\s?(?<PartNum>(?!^).*?))?$";
final String string = "1 60ea ABC A1234-16-32 Description here 8.88/ea 532.80\n"
+ "Possible Extended Description here - do not need this\n"
+ "UPC: 1234567890\n"
+ "2 20ea DEF 866 1562PL Description here 4.44/ea 88.80\n"
+ "UPC: 2234567890\n"
+ "3 10ea GHI 34-12-66-12 Description here 2.22/ea 22.20\n"
+ "Possible extended description";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}