use strict;
my $str = '1 60ea ABC A1234-16-32 Description here 8.88/ea 532.80
Possible Extended Description here - do not need this
UPC: 1234567890
2 20ea DEF 866 1562PL Description here 4.44/ea 88.80
UPC: 2234567890
3 10ea GHI 34-12-66-12 Description here 2.22/ea 22.20
Possible extended description';
my $regex = qr/^\d+\s(?<Quantity>\d+?)(?:EA|RL|BX)\s(?:(?:ABC|DEF|GHI) (?<AltID>.*?) )?(?<Description>.*?) (?<PriceEa>\d+\.\d+)\/ea \d+\.\d+(?:(?:(?!(?:^\d+\s\d+ea|UPC:))(?:.|\n))+)?(?:UPC:\s?(?<PartNum>(?!^).*?))?$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}