$re = '/^\d+\s(?<Quantity>\d+?)(?:EA|RL|BX)\s(?:(?:ABC|DEF|GHI) (?<AltID>.*?) )?(?<Description>.*?) (?<PriceEa>\d+\.\d+)\/ea \d+\.\d+(?:(?:(?!(?:^\d+\s\d+ea|UPC:))(?:.|\n))+)?(?:UPC:\s?(?<PartNum>(?!^).*?))?$/mi';
$str = '1 60ea ABC A1234-16-32 Description here 8.88/ea 532.80
Possible Extended Description here - do not need this
UPC: 1234567890
2 20ea DEF 866 1562PL Description here 4.44/ea 88.80
UPC: 2234567890
3 10ea GHI 34-12-66-12 Description here 2.22/ea 22.20
Possible extended description';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);