#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)A(?=[^)(]*\))"
Local $sString = "A. (AbbAAbb) .A. (bbAbbAbA) .A. (bbbbAbbbb) .A." & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)