re = /A(?=[^)(]*\))/m
str = 'A. (AbbAAbb) .A. (bbAbbAbA) .A. (bbbbAbbbb) .A.
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result