const regex = new RegExp('A(?=[^)(]*\\))', 'gm')
const str = `A. (AbbAAbb) .A. (bbAbbAbA) .A. (bbbbAbbbb) .A.
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);