use strict;
my $str = 'A. (AbbAAbb) .A. (bbAbbAbA) .A. (bbbbAbbbb) .A.
';
my $regex = qr/A(?=[^)(]*\))/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";