import Foundation
let pattern = #"A(?=[^)(]*\))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
A. (AbbAAbb) .A. (bbAbbAbA) .A. (bbbbAbbbb) .A.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)