# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([\s\S]*)(\#)([a-zA_Z0-9]*)(\#)(\s*)(.*)([\s\S]*)/$6/g;t' <<< " 1 OPTION 1
2 OPTION 2
3 OPTION 3
4 OPTION 4
5 OPTION 5
6 OPTION 6
7 OPTION 7
8 OPTION 8
9 OPTION 9
10 OPTION 10
100 OPTION 100
#1000# OPTION 1000
[REPLACEALL]([\s\S]*)(\#)([a-zA_Z0-9]*)(\#)(\s*)(.*)([\s\S]*)[WITH]$6"