const regex = /([\s\S]*)(\#)([a-zA_Z0-9]*)(\#)(\s*)(.*)([\s\S]*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\s\\S]*)(\\#)([a-zA_Z0-9]*)(\\#)(\\s*)(.*)([\\s\\S]*)', 'g')
const str = ` 1 OPTION 1
2 OPTION 2
3 OPTION 3
4 OPTION 4
5 OPTION 5
6 OPTION 6
7 OPTION 7
8 OPTION 8
9 OPTION 9
10 OPTION 10
100 OPTION 100
#1000# OPTION 1000
[REPLACEALL]([\\s\\S]*)(\\#)([a-zA_Z0-9]*)(\\#)(\\s*)(.*)([\\s\\S]*)[WITH]\$6`;
const subst = `$6`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);