import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([\\s\\S]*)(\\#)([a-zA_Z0-9]*)(\\#)(\\s*)(.*)([\\s\\S]*)";
final String string = " 1 OPTION 1\n"
+ " 2 OPTION 2\n"
+ " 3 OPTION 3\n"
+ " 4 OPTION 4\n"
+ " 5 OPTION 5\n"
+ " 6 OPTION 6\n"
+ " 7 OPTION 7\n"
+ " 8 OPTION 8\n"
+ " 9 OPTION 9\n"
+ " 10 OPTION 10\n"
+ " 100 OPTION 100\n"
+ "#1000# OPTION 1000\n\n"
+ "[REPLACEALL]([\\s\\S]*)(\\#)([a-zA_Z0-9]*)(\\#)(\\s*)(.*)([\\s\\S]*)[WITH]$6";
final String subst = "$6";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}