$re = '/([\s\S]*)(\#)([a-zA_Z0-9]*)(\#)(\s*)(.*)([\s\S]*)/';
$str = ' 1 OPTION 1
2 OPTION 2
3 OPTION 3
4 OPTION 4
5 OPTION 5
6 OPTION 6
7 OPTION 7
8 OPTION 8
9 OPTION 9
10 OPTION 10
100 OPTION 100
#1000# OPTION 1000
[REPLACEALL]([\\s\\S]*)(\\#)([a-zA_Z0-9]*)(\\#)(\\s*)(.*)([\\s\\S]*)[WITH]$6';
$subst = "$6";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;