import re
regex = re.compile(r"([\s\S]*)(\#)([a-zA_Z0-9]*)(\#)(\s*)(.*)([\s\S]*)")
test_str = (" 1 OPTION 1\n"
" 2 OPTION 2\n"
" 3 OPTION 3\n"
" 4 OPTION 4\n"
" 5 OPTION 5\n"
" 6 OPTION 6\n"
" 7 OPTION 7\n"
" 8 OPTION 8\n"
" 9 OPTION 9\n"
" 10 OPTION 10\n"
" 100 OPTION 100\n"
"#1000# OPTION 1000\n\n"
"[REPLACEALL]([\\s\\S]*)(\\#)([a-zA_Z0-9]*)(\\#)(\\s*)(.*)([\\s\\S]*)[WITH]$6")
subst = "$6"
result = regex.sub(subst, test_str)
if result:
print(result)