# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<!\S)\d{4}(?!\S)/[[$0]]/g;t' <<< "[[1990]] 2012 c,2014."