const regex = /(?<!\S)\d{4}(?!\S)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\S)\\d{4}(?!\\S)', 'g')
const str = `[[1990]] 2012 c,2014.`;
const subst = `[[$0]]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);