$re = '/(?<!\S)\d{4}(?!\S)/';
$str = '[[1990]] 2012 c,2014.';
$subst = "[[$0]]";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;