use strict;
my $str = '[[1990]] 2012 c,2014.';
my $regex = qr/(?<!\S)\d{4}(?!\S)/p;
my $subst = '[[$0]]';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";