using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\S)\d{4}(?!\S)";
string substitution = @"[[$0]]";
string input = @"[[1990]] 2012 c,2014.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}