# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s?([?|:|;])/#160;$1/g;t' <<< "On pourrait presque limiter Céleste Prudhomat au cas clinique, son étude. La conclusion en serait alors : « Voilà où conduit l’école de la République, voilà où conduit la libération des mœurs ».
On pourrait presque limiter Céleste Prudhomat au cas clinique, son étude. La conclusion en serait alors ; « Voilà où conduit l’école de la République, voilà où conduit la libération des mœurs »."