re = /\s?([?|:|;])/
str = 'On pourrait presque limiter Céleste Prudhomat au cas clinique, son étude. La conclusion en serait alors : « Voilà où conduit l’école de la République, voilà où conduit la libération des mœurs ».
On pourrait presque limiter Céleste Prudhomat au cas clinique, son étude. La conclusion en serait alors ; « Voilà où conduit l’école de la République, voilà où conduit la libération des mœurs ».'
subst = '#160;$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result