package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s?([?|:|;])`)
var str = `On pourrait presque limiter Céleste Prudhomat au cas clinique, son étude. La conclusion en serait alors : « Voilà où conduit l’école de la République, voilà où conduit la libération des mœurs ».
On pourrait presque limiter Céleste Prudhomat au cas clinique, son étude. La conclusion en serait alors ; « Voilà où conduit l’école de la République, voilà où conduit la libération des mœurs ».`
var substitution = "#160;$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}