const regex = /\s?([?|:|;])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s?([?|:|;])', 'g')
const str = `On pourrait presque limiter Céleste Prudhomat au cas clinique, son étude. La conclusion en serait alors : « Voilà où conduit l’école de la République, voilà où conduit la libération des mœurs ».
On pourrait presque limiter Céleste Prudhomat au cas clinique, son étude. La conclusion en serait alors ; « Voilà où conduit l’école de la République, voilà où conduit la libération des mœurs ».`;
const subst = `#160;$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);