const regex = /(?<=Amount:).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=Amount:).*', 'gm')
const str = `Insurance PoIicv Amount: \$1,200,000.00
Insurance PoIicy Amount: J25 1 000 i00_
Insurance Policy Amount: ##5##Q00##0 __`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}