use strict;
my $str = 'Insurance PoIicv Amount: $1,200,000.00
Insurance PoIicy Amount: J25 1 000 i00_
Insurance Policy Amount: ##5##Q00##0 __';
my $regex = qr/(?<=Amount:).*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}