re = /(?<=Amount:).*/m
str = 'Insurance PoIicv Amount: $1,200,000.00
Insurance PoIicy Amount: J25 1 000 i00_
Insurance Policy Amount: ##5##Q00##0 __'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end