#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(\[\w+\]).?|([\w\[\] ]+)"
Local $sString = "[red]" & @CRLF & _
"" & @CRLF & _
"aaa [bbb] hello" & @CRLF & _
"" & @CRLF & _
"[blue]" & @CRLF & _
"" & @CRLF & _
"aaa" & @CRLF & _
"" & @CRLF & _
"[green]" & @CRLF & _
"" & @CRLF & _
"ccc"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")