re = /(\[\w+\]).?|([\w\[\] ]+)/
str = '[red]
aaa [bbb] hello
[blue]
aaa
[green]
ccc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end