import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\[\\w+\\]).?|([\\w\\[\\] ]+)";
final String string = "[red]\n\n"
+ "aaa [bbb] hello\n\n"
+ "[blue]\n\n"
+ "aaa\n\n"
+ "[green]\n\n"
+ "ccc";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}