$re = '/(\[\w+\]).?|([\w\[\] ]+)/s';
$str = '[red]
aaa [bbb] hello
[blue]
aaa
[green]
ccc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);