package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)(\[\w+\]).?|([\w\[\] ]+)`)
var str = `[red]
aaa [bbb] hello
[blue]
aaa
[green]
ccc`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}