using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\G[^\[]*|[^\]].|[^\(])(https?://|www\.)";
string input = @"https://example.com
xt](https://example.com)
[te
xt](https://example.com)
[text](https://example.com)
https://example.com
[text](https://example.com)
ext](https://example.com)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}