const regex = new RegExp('(\\G[^\\[]*|[^\\]].|[^\\(])(https?://|www\\.)', 'g')
const str = `https://example.com
xt](https://example.com)
[te
xt](https://example.com)
[text](https://example.com)
https://example.com
[text](https://example.com)
ext](https://example.com)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}