import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\G[^\\[]*|[^\\]].|[^\\(])(https?://|www\\.)";
final String string = "https://example.com\n\n"
+ "xt](https://example.com)\n\n"
+ "[te\n"
+ "xt](https://example.com)\n\n"
+ "[text](https://example.com)\n\n"
+ "https://example.com\n\n"
+ "[text](https://example.com)\n\n"
+ "ext](https://example.com)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}