re = /(\G[^\[]*|[^\]].|[^\(])(https?:\/\/|www\.)/
str = 'https://example.com
xt](https://example.com)
[te
xt](https://example.com)
[text](https://example.com)
https://example.com
[text](https://example.com)
ext](https://example.com)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end