$re = '~(\G[^\[]*|[^\]].|[^\(])(https?://|www\.)~';
$str = 'https://example.com
xt](https://example.com)
[te
xt](https://example.com)
[text](https://example.com)
https://example.com
[text](https://example.com)
ext](https://example.com)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);