import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:Mr|Mrs|Miss|Dr)\\.\\s*|\\.\\s*(\\w+)";
final String string = "There are a lot of questions about lookbehind, But I couldn't find my answer.\n\n"
+ "My RegExp with negative lookbehind is working fine in chrome but not in IE.\n\n"
+ "I need a regular expression that match any word after a period(.) but there should not be a (Mr) before the period. for example in\n\n"
+ "'I met Mr. Jack this evening. He is a good man', but honestly Miss. Jackson, I am for real.\n\n"
+ "I want to get He, but not Jack (since it is followed by Mr.)\n\n"
+ "so far I have comeup with the mrs. Sullivan regExp which works fine on chrome, But it doesn't on IE. and It is to be run on IE.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}