import Foundation
let pattern = #"(?:Mr|Mrs|Miss|Dr)\.\s*|\.\s*(\w+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
There are a lot of questions about lookbehind, But I couldn't find my answer.
My RegExp with negative lookbehind is working fine in chrome but not in IE.
I need a regular expression that match any word after a period(.) but there should not be a (Mr) before the period. for example in
'I met Mr. Jack this evening. He is a good man', but honestly Miss. Jackson, I am for real.
I want to get He, but not Jack (since it is followed by Mr.)
so far I have comeup with the mrs. Sullivan regExp which works fine on chrome, But it doesn't on IE. and It is to be run on IE.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)