# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:Mr|Mrs|Miss|Dr)\.\s*|\.\s*(\w+)"
test_str = ("There are a lot of questions about lookbehind, But I couldn't find my answer.\n\n"
"My RegExp with negative lookbehind is working fine in chrome but not in IE.\n\n"
"I need a regular expression that match any word after a period(.) but there should not be a (Mr) before the period. for example in\n\n"
"'I met Mr. Jack this evening. He is a good man', but honestly Miss. Jackson, I am for real.\n\n"
"I want to get He, but not Jack (since it is followed by Mr.)\n\n"
"so far I have comeup with the mrs. Sullivan regExp which works fine on chrome, But it doesn't on IE. and It is to be run on IE.")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.