re = /(?:Mr|Mrs|Miss|Dr)\.\s*|\.\s*(\w+)/mi
str = 'There are a lot of questions about lookbehind, But I couldn\'t find my answer.
My RegExp with negative lookbehind is working fine in chrome but not in IE.
I need a regular expression that match any word after a period(.) but there should not be a (Mr) before the period. for example in
\'I met Mr. Jack this evening. He is a good man\', but honestly Miss. Jackson, I am for real.
I want to get He, but not Jack (since it is followed by Mr.)
so far I have comeup with the mrs. Sullivan regExp which works fine on chrome, But it doesn\'t on IE. and It is to be run on IE.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end